Are there minimum browser requirements?

The only browser requirement is that your browser must be HTML5 compatible. We recommend updating your browser to the latest version available—not just to ensure compatibility with the online banking experience, but also to ensure that your online banking is as secure as possible. 

To check if your browser is HTML5 compatible click on this link.

https://html5test.com/index.html

If an FSB associate is helping you troubleshoot an I-banking issue, they may also direct you to this link.